Everything in Spanish...How to Fix?

When looking at everything as a buyer, literally everything is in Spanish. Started almost a week ago and looks like this…

The only option as you see is to translate Spanish into English. If I had lasted more than 3 weeks in Spanish class without flunking out in college, maybe I would know what some of this stuff means… but I digress…

So I go into Language settings so I can change whatever got screwed up back to English. But here is what I have instead…

I only have a choice between Spanish and an English translation of the Spanish page.

I did not make any changes or anything like that. How in the world do I fix this? This is driving me absolutely bonkers and it is so annoying to have to translate into my own native language. I might as well be looking at Sanskrit when looking at Spanish.

Edit to add: Seller Central and associated pages are just fine. No espanol.

1 Like

When you are looking at the product detail page, are you on the .com marketplace?

1 Like

Yes, I am on the .com page

1 Like

What browser?
ASIN? (or is it all of your ASINs or anyone’s ASINs?)

1 Like

Ok that’s strange. Try logging out closing browser and go back in?

1 Like

May I ask if I am correct in presuming that by “…looking at everything as a buyer…” you are referring to what you see for an Amazon Global Catalog PDP (or browse-bin/Store page) when using the same browser that has already been logged into Seller Central for your SoA Account?

If so, may I ask if the same behaviour results from using said Web Browser/OS configuration for an Amazon Buyer Account which is not ‘formally’ associated with your SoA Account, as is the ‘Primary’ Buyer Account automatically associated by Amazon when any SoA Account is created?

Been there and done that.

2 Likes

All asin across the board in Chrome and Edge. I do not have FF

1 Like

I click on “lowest price” in Manage Inventory on any asin I am on and open it in another tab. Entire page is Spanish and I’m very nicely asked if I want the page translated to English.

I then proceeded to go to Amazon.com separately to see if there is any difference. All the same Spanish, regardless.

Flag next to the search box shows the usa flag?

1 Like

May I ask whether or not it is true that using the Marketplace Switcher to navigate to the Amazon.com.mx Seller Central Dashboard (presuming, that like many members of our Seller community, your SoA Account is recognized as being of the NAmU ['“North American Unified”] variety) shows an “Unhealthy” banner/notification?


ETA (“Edit To Add,” not “Estimated Time Of Arrival,” in ‘forum-speak.’):

Pepper’s on the same track in asking about the Marketplace Switcher functionality.

This reason why I posed the question above is not because I’m unaware of the preponderant likelihood of some LSO (“Local Storage Object”) on your end of the client-server exchange which presents you with a language other than that of your established preference proving to be, ultimately, at fault; rather, it’s because I’m aware that Amazon’s GEI (“Global Expansion Initiative”) has produced the recent circumstance of “Unhealthy” warnings appearing for long-neglected Global Marketplaces which are, by default, part of one’s SoA Account.

1 Like

Yes

2 Likes

1 Like

Yes, I am set with the American flag and EN as my language.

2 Likes

Check your settings in Chrome …


Change Chrome languages and translate web pages

If the page is in more than one language, it shows your preferred language first.

  • On your computer, open Chrome.
  • At the top right, click More Settings.
  • At the left, click Languages.
  • Under ‘Google Translate’, click Don’t offer to translate these languages.
  • Click Add languages.
  • Select the languages that you want to add.

:arrow_up: :arrow_up: :arrow_up: :arrow_up:TAKES YOU TO:arrow_down: :arrow_down: :arrow_down: :arrow_down:


Websites will show content in your preferred languages, when possible

Add languages

  1. English (United States)

This language is used when translating pages

  1. English

This language is used to display the Google Chrome UI

1 Like

What happens when you choose ES?
Then switch back to EN?

2 Likes

That would help, but my problem is only on Amazon. Any other website I go to is always in English. I want to actually fix whatever setting is going crazy. I’ve tried every setting imaginable that deals with preferred language and it doesn’t help.

As you can see in this, my only choice is either Spanish or English via translation.

1 Like

Nothing changes. Even after closing my browser and relaunching.

1 Like

Guess you’ll have to marry a Mamita and have her do your amazon shopping.

Do you get the same result in incognito mode?
Then click Www.Amazon.com

Pc or tablet, iPad?

Id clear history & cache

4 Likes