SS call functionality broken

Hello folks,

I need to speak with the Catalog team to try to fix a couple of listings that lost some bullet points. I tried requesting a call through the Seller Support, but after a few seconds, the call simply doesn’t connect and gives the message “Oops! We are having trouble updating the status of your call”. I know it’s not my phone, because I’ve been making and receiving calls all morning.

Has anyone experienced this lately? Hope it’s just a temporary glitch that will be fixed soon, although I don’t think they’ll be that useful anyway :expressionless:

2 Likes

It appears to be a glitch, there have been numerous posts in the NSFE about it; hopefully, it will be fixed later today.

2 days later, still not working… :frowning_face:

Amazon seems to be having a bunch of issues (glitches) at the moment; they are doing a system upgrade/ maintenance, you may have to wait until Monday. :pensive:

Always on Fridays …

:roll_eyes:

2 Likes

On my Pre-Order fiasco I PUSHED the “CALL ME NOW” button.
5 times and received a call every time.

The 5th one I was able to get someone from the USA - So i’m guessing 5 calls in one case gets it escalated to a higher tier of support.

2 Likes