Trying to reprint a label, but instead of sending the label to the printer it is downloading.

I need to reprint a label. When I go into the order and click on Reprint Label, the label gets downloaded as a .zpl file. I can’t see how to change what happens when I click Reprint Label. Any ideas how this happened or how to fix it?

That’s strange, that’s not a browser issue, that’s an Amazon code issue

1 Like

As far as I can tell, yes. This is happening on every computer I have access to, including my work laptop which I do not let any of the incompetent… people I work with ever touch.

Is anyone else having this problem?

Also, how do I print this downloaded .zpl file?

1 Like

Sounds like someone switched from Amazon Print Connect to QZ Tray.

Do you see this image on the bottom of Amazon Buy Shipping when purchasing Bulk (multiple orders at the same time)? With QZ Tray One-Click Printing is enabled.

We had a similar issue when we switched to QZ Tray.

Note: Selecting a PNG option without One-Click Printing (QZ Tray) enabled will result in a browser pop-up window containing all labels together as a single PDF file.


I tried reshipping some other labels from other orders shipped today and those all worked normally. However, this one label that I actually need to reship is still causing problems. I’m even more confused now.

Nothing like this.

Can you still refund the label and Buy Shipping again to make a whole new label?

We had a similar issue because the PNG was set to the wrong printer. When we changed the PNG to match the ZPL then everything started printing correctly.


The option to refund the label is there, I am reluctant to try using it.

Does this help you?

1 Like

I will try this tomorrow.

It’s only happening on this one order. Everything else reprints normally. I’m really at a loss what is going on here.

When you click on the zip file (saved to your computer), does it not appear as a PDF?

It is not being saved as a zip file.

This is what I’m getting.

When I click Reprint Label, it saves the .zpl file directly to my downloads folder. There is no dialogue window, no PDF, and no zip file.


I may be misunderstanding the article, but that seems to be about sending zpl orders to the printer to override its current settings, not about sending labels to the printer.

How do I open a ZPL file in PDF?
How to convert a ZPL file to PDF, JPG, DOCX, TXT, …

  1. Just click the “Choose your . zpl file to view” button on this page.
  2. After your file is opened in browser,
  3. click “Save as…” in the menu.
  4. Then choose the file format (e.g. JPG, PDF, DOCX, TXT, …) you want.
  5. Your file will be converted and downloaded.

Here is the link in reference to item #1

1 Like

When I try to upload the file, it says “Loading data. Please, wait…” Been stuck this way for the last 10 minutes.

It’s been 30 minutes now. I don’t think this is going to work.

Could be a browser or site issue.

Google "convert zpl file to pdf "

There are several references on how to convert a ZPL file to a PDF.
One of them is bound to work.

1 Like

I will keep poking around with this when I have time, and I appreciate the suggestions. But in the end, this is a work around for getting to the shipping label. It doesn’t address wtf is going on with Amazon that it is automatically downloading .zpl files instead of reprinting the label.

1 Like

Maybe try this one

Open the file in the left side and then download PDF in the right side


This one works like a dream, thanks.